Nagios is monitoring the IBM i.

In a recent Post we mentioned that we were working away on a new Nagios build that would form the base for our Nagios monitoring for the IBM i, well we are now very close […]

SMS from IBM i for Monitoring

We have been looking at the Nagios monitoring solution for the last few weeks and wanted to add some way of sending SMS alerts out to phones for critical events that require immediate notification. Nagios […]

Connecting to External Mail Server

The HA4i product has the ability to send emails through port 25 which is the standard non secured SMTP port. The problem with this is some servers do not allow connection via this port unless […]

HA4i gains new features using Let’s ‘C’ technology

We have previously posted about how to connect to a remote web server from your IBM i using both secure and non-secure sockets as part of a series of open source snippets (Let’s ‘C’) we […]

Let’s ‘C’ using TLS to the web.

Its been a long few weeks since the last real techie post. We had a number of issues with the Secure Sockets program talking to our externally hosted website which took a lot of debugging […]

Let’s ‘C’ integration with security

The previous post started a Server process which could receive ASCII based input, although it was pretty limited in terms of what it did it did show some of the basics required to build a […]

System and Software for journaling system objects patent EP 1559019 A1

To view the above patent please click here. Why the interest My interest was peaked by a recent LinkedIn comment about how using the Audit Journal to capture replication requests was a poor design choice. […]

Been a very busy winter period.

Winter in Canada can be a very long affair and as we know its been a very hard and cold winter this year. This has kept us locked in the office for a lot longer […]

PASE to the rescue..

I was working with a client over the Holidays looking at an issue where our save processes for the IFS kept failing to get a lock on a couple of IFS objects. The problem meant […]

QNAP and NFS issues

I don’t know why, but the setup we created for backing up to the QNAP NAS from the IBMi LPARS stopped working. We have been installing PTF’s all weekend as we try to get Node.js […]