Vista Business Connected to IBM 'i' NetServer

After many months of trying to connect to the Netservers and giving up in frustration I have finally managed to work out what to do. For those others who have the same issues here is a quick guide on how I achieved it! The Netshares were perfectly accessible from XP systems and we could connect to other SMB shares on other systems, just the IBM ‘i’ gave us problems! Go figure…

First of all start a DOS session and enter Secpol.msc this should result in the following screen:

Security Policy Editor
Security Policy Editor

Once here you need to select the Local Policies/Security Options folder from the left window then select the Network Security: LAN Manager authentication option as shown here:

Select the Security Options
Select the Security Options

Now all you have to do is set it to use the Send LM & NTLM – use NTLMv2 session security if negotiated which is done by right clicking the option and selecting the properties option which will show the setting panel, use the drop down to select the correct option as described above.

Authorization Level
Authorization Level

Once you have done this sue the Apply buttons etc to make the changes before rebooting your computer. When it is back up you should be able to browse the IBM ‘i’ netshares you have defined….

Hope this helps others who like us became frustrated with the Vista – IBM ‘i’ support..

Chris…

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.