Compiles not returning correct information in WSDc

I am trying to get IBM to look into a problem where WSDc does not return all of the messages that should be generated when I compile a list of modules.

I am simply right clicking the member in the file list and submitting a number of them individually. I do this before the first compile is completed so in effect I have queued up requests to compile each object one after the other. The problem is I don’t get the messages back stating if the compile worked or not or the error list showing any warnings etc? The log shows each job is loaded for compilation but it does not show how they completed of any warnings etc which were issued for each object. If I do each one in sequence after each has finished I get all the messages and the log shows the correct message sequence.

The question is has anyone else seen this problem? If so how did you get over it? IBM says they cannot reproduce yet I can do it at will as long as the first compile is long enough that the follow on compiles can be selected and submitted before it returns.

Here is a list showing the sequence in the log.

ADDLIBLE RAP410SRC *LAST
Library RAP410SRC added to library list.
Cause . . . . . : If the ADDLIBLE command was used, RAP410SRC was added to the user library list. If the CHGSYSLIBL command was used, RAP410SRC was added to the system portion of the library list.

SBMJOB CMD(CRTCMOD MODULE(RAP410SRC/RAP00101) SRCFILE(RAP410SRC/QCSRC) SRCMBR(RAP00101) OUTPUT(*PRINT) OPTION(*EVENTF) DBGVIEW(*SOURCE) REPLACE(*YES)) JOBD(*LIBL/QBATCH)
Job 129043/RSEUSER/QBATCH submitted to job queue QBATCH in library QGPL.

SBMJOB CMD(CRTCMOD MODULE(RAP410SRC/RAP00102) SRCFILE(RAP410SRC/QCSRC) SRCMBR(RAP00102) OUTPUT(*PRINT) OPTION(*EVENTF) DBGVIEW(*SOURCE) REPLACE(*YES)) JOBD(*LIBL/QBATCH)
Job 129044/RSEUSER/QBATCH submitted to job queue QBATCH in library QGPL.

SBMJOB CMD(CRTCMOD MODULE(RAP410SRC/RAP0011) SRCFILE(RAP410SRC/QCSRC) SRCMBR(RAP0011) OUTPUT(*PRINT) OPTION(*EVENTF) DBGVIEW(*SOURCE) REPLACE(*YES)) JOBD(*LIBL/QBATCH)
Job 129045/RSEUSER/QBATCH submitted to job queue QBATCH in library QGPL.

CRTCMOD MODULE(RAP410SRC/RAP00101) SRCFILE(RAP410SRC/QCSRC) SRCMBR(RAP00101) OUTPUT(*PRINT) OPTION(*EVENTF) DBGVIEW(*SOURCE) REPLACE(*YES)
Module RAP00101 was created in library RAP410SRC on 12/08/08 at 14:20:14.
Cause . . . . . : Module RAP00101 was successfully created in library RAP410SRC. If the date and time of creation is missing, you may not have authority to the module object.

SBMJOB CMD(CRTCMOD MODULE(RAP410SRC/RAP00102) SRCFILE(RAP410SRC/QCSRC) SRCMBR(RAP00102) OUTPUT(*PRINT) OPTION(*EVENTF) DBGVIEW(*SOURCE) REPLACE(*YES)) JOBD(*LIBL/QBATCH)
Command has completed

You can see that I get a message back stating how the first submission ended and a message stating that the second completed. But no details on the second submission or any there after? The modules do get created even though they all have a multitude of warnings (I use Binding Directories to provide some functionality and the initial modules don’t know about them until the CRTPGM stage).

If you have seen this problem and managed to get over it let me know as IBM is not able to help it seems?

Chris…

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.